Heartbleed vulnerability fixed

Recently a weakness was discovered in OpenSSL, the secure cryptographic communication library that just about every site on the web relies upon. A patch was recently issued, and we’ve upgraded our infrastructure so that we’re no longer vulnerable. 

That is all, carry on.

Sorry, comments are closed for this post.